Screen Shot 2012 09 24 at 21.36.12 FIX: Check Point Endpoint Security unable to connect
UPDATE: it would appear this bug has since been resolved in the E80 release of the CheckPoint client.

Since my recent upgrade to OS X Mountain Lion I’ve been suffering a very frustrating issue with Checkpoint’s endpoint security client. For no reason at all it would frequently refuse to connect. Stating an error: “Connectivity with the Check Point Endpoint Security service is lost”
Despite trying countless things with the client I found the only fix each time was to reinstall the client.

That was until now at least, after further investigation it looks like the issue only occurs when the Trac.config file had been zeroed. Now, I’m still trying to figure out what’s happening to the file. But I found in the meantime if you kill the checkpoint client then perform the following in terminal:

$ cd “/Library/Application Support/Checkpoint/Endpoint Connect”
$ sudo cp Trac.config.bak Trac.config

Then client the starts working as expected. Alternatively you can download a compiled AppleScript from here to do just that!
NB: You will be prompted for your admin credentials when either executing the command, or the script.

If you’ve found an alternative solution, please let me know in the comments below.

Tagged with:  
  • Markus Meier

    I also have this issue when i’m trying to connect from my mac at home. Strangely this is the only source i found for this after a longer time of googling.

    • http://www.mikesel.info/ Mike Hudson

      Glad to have been able to help out!

      Thanks for taking the time to comment.

      Cheers
      Mike

  • David

    Thanks Mike. That worked a treat!

    David


Looking for something?

Use the form below to search the site:

Still not finding what you're looking for? Drop a comment on a post or contact us so we can take care of it!